The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only > Cranks and won't start

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Cranks and won't start Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-09-2014 09:33 AM
DrewP So what did the fix turn out to be?
10-08-2014 05:45 PM
Wingnut Thanks Drew. You are the whole reason I registered on this site to begin with. Glad to finally hear from you. I read quite a few posts and yours are by far the most intelligent. Just fired the car up about 10 minutes ago. I had already checked (loosened/tightened) grounds and you are correct about the wiring. No rodent damage, just rotten Swedish wiring back feeding the ECM and causing all the chaos. Lucky this computer is still good.
10-08-2014 05:18 PM
DrewP The main relay isn't closed by the ECU, knee-jerk guess is the ignition switch (they do weird things when they start to go bad), or someone monkeyed with the ground lugs for the engine harness on the side of the intake manifold, or maybe wiring is damaged from a rodent or something.
10-08-2014 11:26 AM
Wingnut Can anyone here post a diagram for engine computer on 2001 9-3 turbo?
10-08-2014 11:24 AM
Wingnut CPS was changed prior to arrival here. No change.
10-08-2014 05:43 AM
Saabeh No spark or injector, have you swapped the crank position sensor?
10-07-2014 06:18 PM
Wingnut
Cranks and won't start

2001 Saab 93 turbo. Engine cranks and will not start. No spark or injector pulse. Also no communication with engine computer. Have tried Tech 2, snap on and OTC. Main and fuel pump relays are clicking on/off rapidly with key on (buzzing). Replacing relays made no difference. Ground circuits (from ECM?) to both relays are both cycling rapidly resulting in relay buzz. Suspecting failed ECM however, have no diagram to confirm this and test power/grounds etc...

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 07:20 PM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.