The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only > Odd noise at 0psi boost

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Odd noise at 0psi boost Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-15-2014 10:35 AM
DrewP Is the vacuum line for the BPV hooked up correctly?

The red snap fittings for the booster lines ok, and not cracked or loose? Check valve for the brake booster?
09-14-2014 03:27 PM
seriks1 I've had a few that will really howl on the initial start up from leaky brake boosters. The noise was less pronounced after a few seconds of running. Sounded just like a bad BOV
09-14-2014 02:56 PM
kalbers Swapped out the bov and still same noise. Any other ideas?
09-12-2014 05:01 PM
kalbers Ya that's what I was thinking as well, ill track one down and swap it out and see if that helps
09-12-2014 08:27 AM
Saabeh Yep its probably the BPV.
09-11-2014 04:58 PM
DrewP BPV is first thing to check, put an extra length of vacuum line on the nipple and suck on it to see if it'll hold vacuum. If you can breath air through it then it's bad.
09-11-2014 04:19 PM
kalbers
Odd noise at 0psi boost

Car is a 2003 saab 9-5 aero with 76k on it. Recently what has been happening is when the car is neither in vacuum nor boost but in 0psi on the turbo gauge there is a like a grown or howl coming from the left side of the car. If I put to into boost or let off gas so it's back in vacuum it immediately stops the noise. It's only at this one point of throttle that the noise is made. Vac lines are good, could it be the bov?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 09:55 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.