The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > General NG900 / Old 9-3 Posts and Information > Slight leak from automatic transmission case

General NG900 / Old 9-3 Posts and Information Please post general topics pertaining to the NG900 and old 9-3.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Slight leak from automatic transmission case Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-09-2014 06:38 PM
condaddy Lol well I will be keeping my eyes on the fluid level forsure. I suppose it will come back out in the winter and do it in my garage. I just don't understand why it didn't leak at all till it sat for a few weeks..
09-09-2014 03:23 PM
soccerrplyr Here's the half-assed approach answer. If you don't have the time/patience to redo the drop, just live with the small leak and top off the auto-fluid every now and then until you feel like it or until you run the car into the ground. The weather is turning colder so you'll have a decision to make soon.
09-09-2014 01:34 PM
condaddy Lol you are probably right, I just don't want to take it out again and what if it happens again lol. Hopefully someone will say something that's worked for them but prob not. O well we shall see
09-09-2014 11:33 AM
B202nut-2.0 USUALLY:

Most mechanics would suggest against any additives to fix a leak....

From my knowledge, additives that are suppose to stop leaks do so by softening/swelling old gaskets.

According to your post, you used anaerobic stuff, so if you put in an additive, I am not sure its gunna help you.

I know its not what you wanna hear but it may require you to try again...

but maybe others will have another out for you.

'
09-09-2014 11:03 AM
condaddy I don't if it leaked before I had it, and I also don't know what the manual calls for. I would like to avoid dropping the trans if possible. It didn't leak until it sat for a few weeks
09-09-2014 09:22 AM
B202nut-2.0 try resealing the tranny properly. if it wasn't leaking before and now leaking after you troubled it, seems like it didn't seal well...


I like RTV over anaerobic.... what is recommended by your manual?
09-09-2014 09:17 AM
condaddy
Slight leak from automatic transmission case

So I recently changed my auto trans a few months ago, and while changing it I changed the filter inside it. So in doing that it ment I had to take the trans in half. So I did and cleaned off the old rtv sealant really well. I then used anaerobic sealer to seal it. Let it sit together for a few days before being put on the car and filled up. Also filled it up with dex VI instead of orginal dexIII.

Fast forward to a few weeks ago I noticed I had started loosing coolant and burning it off. Later diagnosed it with a bad headgasket. So I decided to park my car in my garage for the last few weeks while I aquire all my part. The other day I noticed a very small wet spot on the ground right above the trans. So wiped the bottom of the trans with a paper towel and sure enough it was trans fluid.

Now before I noticed any fluid from the trans i was always checking under my car where ever I went for and puddles, never had any other than from a leaky coolant line on the turbo.(which is also getting fixed w the hg job).

So now my question is what caused this leak?
Not a good job on the sealant?
Could it have anything to do with sitting for a few weeks?
Could it be that the synthetic dexVI is to thin?

Now how to fix it? Any other ideas other than taking the trans off and redoing it?
Any safe to use trans stop leak?
Maybe try re tightening the bolts on the trans?
Maybe switch back the fluid?
Or can you doing something ghetto and re apply sleant on the out side? Or is that a dumb idea?

Looking for any input!
Thank you Connor

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 08:03 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.