The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   General NG900 / Old 9-3 Posts and Information (https://www.saablink.net/forum/forumdisplay.php?f=23)
-   -   is my Viggen making healthy boost? (https://www.saablink.net/forum/showthread.php?t=7282)

Jameson 01-19-2006 08:12 PM

is my Viggen making healthy boost?
 
OK so I am wondering if my new boost gauge was hooked up right. I am at sea level and its been nice and cool here. I maybe havent been paying enough attention....but I have not seen maybe more then 11psi on the gauge yet. At the same time my stock gauge shows at the end of orange bordering on red which I would take it for healthy.

So I was thinking that maybe when it gets hotter out, the car will show more boost to make up for the less dense air and show higher boost on the gauge and right now it doesnt need to.

Or is my boost gauge not hooked up right?

WyldSaabMan 01-19-2006 08:23 PM

You got it...in the summer you will most likely see higher boost due to the thinner air.

Since T7 boosts to a specific air mass value, it stops boosting when its been reached which comes quickly in this cool dense air.

In the thin air it will boost higher...I believe viggens can go as high as 20psi stock if they are at altitude (or any real thin air)

So all should be well

Jameson 01-19-2006 08:28 PM

Quote:

Originally Posted by WyldSaabMan
You got it...in the summer you will most likely see higher boost due to the thinner air.

Since T7 boosts to a specific air mass value, it stops boosting when its been reached which comes quickly in this cool dense air.

In the thin air it will boost higher...I believe viggens can go as high as 20psi stock if they are at altitude (or any real thin air)

So all should be well

Ok good, that was what I was thinking. It shows that its reached the output its supposed to without needing higher boost. Some people on car domain throw out numbers about this thing and 20psi(20.3 to be exact) but it doesnt work that way lol. If I was running 20psi at sea level my pistons wouldnt like me very much :P

mg_td 01-19-2006 09:30 PM

ive been around 10 psi since august..... woooo

StX221 01-20-2006 04:34 AM

hey jameson,
when you tapped the line for your gauge, could you have tapped into the line for the bypass valve??
i know i did that when i first hooked up mine and it gave a very false reading of 10-11psi. that might be something to look into. i've had it fixed right for a while now and only 6-8psi:(. need some software quick to change that one.

Nick

WyldSaabMan 01-20-2006 05:19 AM

PSI means nothing on T7...sure it sounds cool to say to your friends I am boosting to 25psi...but in reality the beuaty of T7 is if the air is cool and dense you may only need 6-8 psi to make stock powerlevels. Once it hits the airmass value the car lets the wastegate open up.

You guys have the ability to go to a high altitude and still make stock power, whereas us guys with T5 may loose power...sure we will be still boosting to are same value that we were when we were at see level, but it will be 15psi of thin air....where you T7 guys may boost to 10psi here at sea level. when you go to altitude the ECU may adjust up to 20psi.

StX221 01-20-2006 05:28 AM

right, that i understand, which is really cool. I think its great that i can drive to 10,000feet and still make the same power.
But its also nice to know what your boosting to, so if theres a problem it can be easily seen. i know a couple times i have seen my guage drop and realized that i blew off an intercooler connection. (not anymore though. finally got it fixed.)

Nick

WyldSaabMan 01-20-2006 05:31 AM

well yea of course you want a guage so that you know the car is operating correctly

abdukted1456 01-20-2006 05:57 AM

8 Attachment(s)
it is much better and safer to make power on the advanced ingition timing than tons of boost. less chance of knock! that is one of the good points about t7!

and why in winter these cars go like mad!

StX221 01-20-2006 06:02 AM

Quote:

Originally Posted by abdukted1456
and why in winter these cars go like mad!

Nope, thats just your magic turbo! i want a magic turbo too. ive just got a regular one :(haha just kidding

Nick

Jameson 01-20-2006 06:42 AM

Quote:

Originally Posted by StX221
hey jameson,
when you tapped the line for your gauge, could you have tapped into the line for the bypass valve??
i know i did that when i first hooked up mine and it gave a very false reading of 10-11psi. that might be something to look into. i've had it fixed right for a while now and only 6-8psi:(. need some software quick to change that one.

Nick


I didnt put it in myself. I had my shop do it while it was there to have my radar detector hard wired. I think everything is fine. The guage reads 6psi or so in first which I think is right. And hearing other Viggens say they are only boosting to 10psi in the cold shows that I am not alone.

StX221 01-20-2006 07:40 AM

i would go out and look at it if i were you. mine was the same way, 5-6 psi in first and 7-8 and dropping off (power limiter) and then 10 in all the other gears.

the gauge shouldnt be tapped into the tubing for the bypass valve.

Nick

Jameson 01-20-2006 08:29 AM

Quote:

Originally Posted by StX221
i would go out and look at it if i were you. mine was the same way, 5-6 psi in first and 7-8 and dropping off (power limiter) and then 10 in all the other gears.

the gauge shouldnt be tapped into the tubing for the bypass valve.

Nick


OK, I will go look now. IN the mean time I am meeting up with Todd on Sunday who lives 20 mins away and has the exact same car :P

Jameson 01-20-2006 08:33 AM

So I looked and the hose coming off the BPV is untapped and goes directly into a small black solenoid on the firewall. From the same solenoid is an equal size hose thats been T'd and some wire lool goes under the fusebox, that looks to the where they tapped the line and I think thats how it should be.

WyldSaabMan 01-20-2006 08:51 AM

Nick I heard on T7 you do not want to tap the Dump valve line....

StX221 01-20-2006 09:14 AM

Quote:

Originally Posted by WyldSaabMan
Nick I heard on T7 you do not want to tap the Dump valve line....

thats correct. i was just making sure jameson's wasnt hooked up wrong, which would giv a false number.

Nick

WyldSaabMan 01-20-2006 10:28 AM

oh ok I misread your other post and thought you said it should be there...I reread and I saw the shouldn't


All times are GMT -8. The time now is 05:32 AM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.