The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   General NG900 / Old 9-3 Posts and Information (https://www.saablink.net/forum/forumdisplay.php?f=23)
-   -   aftermarket radio and working SID? (https://www.saablink.net/forum/showthread.php?t=108345)

turbojohnny 10-25-2015 02:27 PM

aftermarket radio and working SID?
 
I remember when I had my first 900 I had installed an aftermarket head unit, but the functions of the sid no longer worked, as far as dte and avg mpg.

is there a way to install an aftermarket radio and still have the SID function properly?

srp 10-26-2015 07:10 AM

That's strange, they should not be affected.
You should only lose display of radio related displays.

turbojohnny 10-26-2015 02:33 PM

I'm pretty sure i remembered them not working. maybe I'm wrong. it'd be great to be sure. I'm contemplating installing an aftermarket head unit. but I want my avg mpg and dte to function properly.

chevyman 10-26-2015 03:17 PM

Ive never seen that happen before, even in a couple og-9-3's. Ive had an aftermarket radio in my ng900 for many years with no effect on those sid functions

RaleighSaab 01-26-2016 02:11 PM

That is happening to me now. I had a Pioneer head unit installed and the SID no longer gives information on the SID for anything but temperature and time. The other odd thing is that it seems to flash every 15-20 seconds, like a short. The place that put it in cannot find any issue. Still investigating.

srp 01-26-2016 04:40 PM

Which SID do you have? How many buttons?

TheSaabNinja 01-28-2016 05:02 PM

Huh... when I had an aftermarket unit in my '98 GOOSE I still had all of the info sans radio station. sounds like someone didn't wire it right?

Jeremy R. 02-20-2016 07:57 PM

Quote:

Originally Posted by RaleighSaab (Post 2129921)
That is happening to me now. I had a Pioneer head unit installed and the SID no longer gives information on the SID for anything but temperature and time. The other odd thing is that it seems to flash every 15-20 seconds, like a short. The place that put it in cannot find any issue. Still investigating.

If it's flashing, then chances are there's something connected to one of the bus wires in the radio's wiring harness. It's pretty common for a VW radio harness to have that problem, and VW harnesses are what most people use for aftermarket radios in Saabs. A lot of those have the antenna trigger in the same position that Saab uses for a bus wire.


All times are GMT -8. The time now is 01:18 PM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.