The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   Car Problems? NG900 or old 9-3 Only (https://www.saablink.net/forum/forumdisplay.php?f=27)
-   -   Engine Cutting Off (https://www.saablink.net/forum/showthread.php?t=94962)

AndrewRancourt 08-19-2014 02:12 PM

Engine Cutting Off
 
Hey guys, hoping some of you may have dealt with symptoms like this... The viggen is seldom driven these days due to work being within walking distance. The past few times I've swapped my plugs (gapped torqued etc) the car would idle nice and smooth, but as soon as I hit positive boost, the car would buck once and the engine would cut off. Previously I'd swap back in the older plugs and it ran fine for a bit, until more recently when boost would peak at 7psi (might just be a boost leak?).

Knowing intervals have been very long since parts have been swapped, if ever, I just put in new plugs, a new DIC, Maf, and BPC. I let the car warm up and drove up the block from my house. As soon as boost pressure hit about 10psi or so, I heard a little pop (misfire?) and the car cut off. I have a scan gauge and the are no CELs to read. Before I have this thing shipped up to Harvey (fair warning) any input would be greatly appreciated.

car has around 155k mi

thanks so much,

Andy

oliversexpedition 08-20-2014 01:57 PM

Intercooler or vacuum hose?

DC_SAAB 08-21-2014 03:36 AM

I was going to say the same thing.. since you didn't get a CEL related fault... it does read like a vacuum line at the PCV or near the base of the throttle body or not routed correctly on the BPC. Pics???


All times are GMT -8. The time now is 11:34 AM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.