The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   Car Problems? NG900 or old 9-3 Only (https://www.saablink.net/forum/forumdisplay.php?f=27)
-   -   Stalling/engine light in 99 Saab 9-3 (https://www.saablink.net/forum/showthread.php?t=101498)

WLDSAD 03-17-2015 05:31 PM

Stalling/engine light in 99 Saab 9-3
 
Hello you all, new to these forums and we need some help with an issue.
We purchased the 99 Saab 9-3 back in February, and it has been running smooth. About one/two weeks ago it started sputtering when slowing down to a stop or light, but would not shut down. It progressed to a complete stall, once the car is stopped. At this same time, if we pull up to fuel it will stall then it becomes difficult to start, we have to let it sit for a min or two. We took it to an Auto parts store and had a diagnostic run. It came back with three codes, not sure that these are even the right codes, but he said they could do it. Last night I took it to get fuel, while coming back it did a complete shut down on me when coming to a stop light. Got it started and it wasn't five min she stalled again.

*The first code is P1171, Heated oxygen sensor-Bank 1 Sensor 1 (H02S11) fuel system lean during acceleration.

*Next code P0171, Fuel trim bank one condition

*Last code P0340, Cam sensor condition

As far as the oxygen sensor goes, the young man could not figure out or find out which sensor the car takes. If this is even the issue or just part of another issue altogether. And my understanding is that this car doesn't have a camshaft position sensor.

So what's your take on this?
Really do love this car, hope its nothing to serious :frown:
Thanks
SAD

oliversexpedition 03-17-2015 05:41 PM

I would start by looking at all the rubber vacuum hoses and making sure that they aren't leaking or disconnected. I would also check the evaporation purge valve and see if its connected or possibly bad.

There are two o2 sensors (most likely the first or one before the cat). Not sure what part of the country you are in, but try and locate an independent Saab mechanic or at least someone that has a Tech-II test equipment. The generic code readers don't tell the whole story that the specialized Saab equipment might.

WLDSAD 03-18-2015 02:02 AM

Thank you for your help
We're located here in Louisa, Va.
Ill try to locate someone today.

I forgot to mention too. That the car has also been alarming
* check coolant fluid, *check gas cap, * (something) theft system
when we check the coolant seems fine, doesn't run hot. The cap is ok too, and I have no clue about the alarm system.
Possibly related ?

Thanks for your help, much appreciated

Aman245 08-04-2015 10:10 PM

With the fuel trim code, I might say that you're having fuel pump issues. But O2 sensors might do that as well. Hm.


All times are GMT -8. The time now is 04:34 AM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.