Engine Troubles - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-08-2014, 05:00 AM   #1
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
Engine Troubles

Okay ill keep this short but my engine likes to stall out when coming to a stop getting off the highway. If I downshift through the gears its okay but if I pop it into neutral itll idle at 500 and stall out. Also the gas pedal is doing weird things, basically the first maybe 1/4 of travel issues no response from the engine. What do? Tia
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-08-2014, 05:26 AM   #2
lms
Live, eat, and sleep by TSL
 
Join Date: Jan 2006
Posts: 1,337
Check for vacuum leaks, clean iac and make sure u r not in limp mode if your car has that.
lms is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-08-2014, 06:03 AM   #3
 
mike saunders's Avatar
 
Join Date: Mar 2004
Location: Boston, MA
Posts: 6,468
Quote:
Originally Posted by lms View Post
Check for vacuum leaks, clean iac and make sure u r not in limp mode if your car has that.
This....

Especially the IAC and all hoses leading to and from it. That big J-shaped one can sometimes work loose, or get a crack where it's clamped.
mike saunders is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 03-08-2014, 06:34 AM   #4
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
I've clean the iac once already. I have another one so I plan on cleaning/swapping them out. Vac lines are have been replaced with silicone
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-08-2014, 12:04 PM   #5
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
Would that explain the throttle issue to?
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-16-2014, 07:41 AM   #6
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
Ive been messing with different aic valves and finding vac leak after vac Ive been fixing and for awhile I had a bit of a high idle around 1500 or so but the engine wasnt stalling out anymore so I lived with it. Now though for the past three days or so the car started to idle normally but then started to stall out and idle at 500 again. The more annoying issue though is this delayed throttle response bull.

So my question is this - can a malfunctioning aic cause a delayed throttle response or should I be looking elsewhere like the tps or something?
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-16-2014, 08:51 AM   #7
Elder
 
turbojohnny's Avatar
 
Join Date: Feb 2008
Location: Orchard Park, ny
Posts: 3,884
Have you checked the vacuum line to your map sensor?
turbojohnny is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-16-2014, 09:21 AM   #8
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
Quote:
Originally Posted by turbojohnny View Post
Have you checked the vacuum line to your map sensor?
It didn't look terrible but I can replace it anyway with some silicone
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-29-2014, 12:20 PM   #9
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
Just tried a brand new out the the box aic valve and the car still doesnt like to idle along with the delayed throttle response. Im really starting to wonder about the tps now. All the vac lines are good, new plugs and it will get 24 mpg on the highway.
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-30-2014, 06:57 AM   #10
SAAB Road Master
 
Join Date: Oct 2007
Location: From Pinckney, Michigan.
Posts: 361
Send a message via AIM to mlemorie Send a message via MSN to mlemorie
I was going to suggest your TPS as well. When I threw the junkyard engine into my car, I missed the TPS plug and had a lot of similar issues to what you are listing.
__________________
1995 900 S Eucalyptus Green
2.3l 5spd
Stage: Zombie
mlemorie is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-30-2014, 04:55 PM   #11
Flirting With TSL Addiction
 
Join Date: Dec 2010
Posts: 579
You might also need to lubricate the throttle cable; spray some penetrating oil into the cable sheathing near where it connects to the throttle body.
Generally, if you get a vac leak, it will idle high and stay high. If there is a hole in the IAC hose, it will not make boost properly, and/or it will idle high--it won't idle low and stall. Instead of throwing parts, you can measure the resistance across the terminals of the TPS and cross reference that with the WIS values. You can also see relative throttle position with an OBDII scanner.
-Cm
__________________
T5 Suite Stg GpopT28, Deka 630's, Walbro 255LPH, 3 bar MAP @ 1.92Bar, W/M, Stg2 clutch, full suspension/bushes, 308mm brake upgrade, 3" turbo-back, big-azz FMIC &Oil-cooler, and fwdlol diapers.
Cm452 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 04-10-2014, 07:14 PM   #12
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
Gonna switch gears a bit here but I'd like to ask about the strut mounts going on here, as in how do i loosen the nut on top. I saw on the brothers ng900 the strut on the Allen key slot and room for a wrench but it doesn't appear to be the case on the 93.
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 04-12-2014, 04:13 AM   #13
Elder
 
132417SAAB's Avatar
 
Join Date: Apr 2007
Location: nashua, NH
Posts: 3,937
Jumping back to the engine sides of things yesterday with the temps over 60 the car would stall out everytime coming to a stop. Today with the temps under 40 its fine
__________________
99 9-3 se
91 Plantana Grey Carlson 9k

This is my car, and it's for me. This is not for you


132417saab™©
AKA "numbers"
132417SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:35 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright © The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.