Hunting/Surging idle on '99 9-3. Not O2 snsrs (??) - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-25-2011, 10:55 PM   #1
TSLMember
 
Join Date: Sep 2010
Posts: 29
Hunting/Surging idle on '99 9-3. Not O2 snsrs (??)

Hey, everybody (ala Dr. Nick)!

OK - this isn't about my '00 9-3 SE, but my 18 y-o cousin's '99 9-3 base.

We are gung-ho to iron this out before this weekend, when he'll be wheeling around his prom date in the beast... his engine is slow to start (has to crank it over a few times), and once it IS running, the idle hunts and surges. Throttle response is also a bit delayed.

A bit of recent parts history... we've replaced ignition cassette and both O2 sensors (DIC 12/10, and oxygen sensors last week).

Before replacing the O2s, the CEL was on and spitting out codes about P0135, P0141, and P0340. Yes, that last one made us think that it was the ignition cassette... AGAIN! But not so. Now, P0141 and P0340 are the only codes to post.

The night that we were wrapping up the O2 sensors we saw that he had a massive PCV leak - the neck is broken off, and the smaller vacuum tube that goes to the throttle body/manifold was disconnected. Would this trigger O2 codes, though?

I guess it's possible... about 4 years ago I had a '96 BMW 328i (OBD-II), and it had a doosey of a PCV valve vacuum - a 1" tube, as a matter of fact. It had deteriorated, and actually caused erratic idle and misfire (and triggered 2 O2 sensor codes). At the time I simply patched it up with black duct tape and the engine ran like new. Simple as that...

But the jury is out on that, as he's 18, in high school, and has yet to get his ass to Advance to get some vacuum line. ps Obviously, the PCV neck is specific to SAAB, but could he use a generic PCV check valve, or does it have to be OEM spec?

SO... ideas anybody? Feel free to jump in on the PCV valve/vacuum theory, or think outside the box. I just don't know that the PCV valve leak would be substantial enough to cause his idling issues. But perhaps that's messing with the MAP sensor?

Also, I'm going to clean the MAF - that's located on/under the air filter box???

Guys (and ladies)... thanks in advance! I look forward to hearing what the SAAB experts/enthusiasts think.

-Andrew
SwedeSpeed93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-26-2011, 05:55 AM   #2
Live, eat, and sleep by TSL
 
spgeebee88's Avatar
 
Join Date: Jul 2005
Location: Athol, MA
Posts: 1,958
Send a message via AIM to spgeebee88
EVAP PURGE VALVE! (the little black valve on the passager side strut tower)

/endthread

they're notorious for failing on T5 cars and causing all sorts of weird problems
spgeebee88 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 04-27-2011, 09:01 PM   #3
TSLMember
 
Join Date: Sep 2010
Posts: 29
spgeebee88

Ahhh, you have a SPG... nice! OK, I'll check the purge valve (or just replace it). Is it that they fail, then vacuum is lost between that and the manifold? (I'd look at it right now, but my cousin lives an hour away, and my '00 9-3SE has a different layout)

ALSO, does the '99 9-3 have a MAF? Or does it use a MAP (manifold absolute pressure sensor)??? I wasn't able to locate a MAF last time he was down - he's driving down tomorrow and I only have a few hours, so I don't want to waste precious time looking for something that isn't there. Anybody?

Thanks!
SwedeSpeed93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 04-27-2011, 09:03 PM   #4
Elder
 
dan-the-kid's Avatar
 
Join Date: Mar 2007
Location: Boston, MA
Posts: 7,349
Quote:
Originally Posted by SwedeSpeed93 View Post

ALSO, does the '99 9-3 have a MAF? Or does it use a MAP (manifold absolute pressure sensor)??? I wasn't able to locate a MAF last time he was down - he's driving down tomorrow and I only have a few hours, so I don't want to waste precious time looking for something that isn't there. Anybody?

Thanks!
No MAF, but you're right, there is a MAP sensor. Its on the passenger side of the strut tower brace.
__________________
Yeah, T5.2 its -.3 better then the rest.
1989 900 SPG: Trionic 5(stg1), Aero seats, TD04-15G, 3" Turboback. SOLD
1993 9000 Aero: 3"Turboback, T5Suite Stg.3
dan-the-kid is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 04-28-2011, 05:13 AM   #5
Live, eat, and sleep by TSL
 
Aikmanson's Avatar
 
Join Date: Mar 2010
Location: Lomontville & Cortland, NY
Posts: 1,837
I battled a bucking/cutoff in my car for a while, replacing everything known to man. I do not think your PCV hose is causing anything, mine blows off from time to time and its not that noticeable performance wise. I would say check EVAP purge valve, MAP sensor, AIC valve (probably 1st bet to be honest, remove it and clean it out then reinstall).

Check those first and report back what you think. Also did you replace spark plugs when you put in the new DIC...? proper gap exct.?
__________________
Current Cars
2010 Mini Cooper S
1991 Miata
1995 900 SE Turbo
Aikmanson is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 04-29-2011, 09:02 AM   #6
TSLMember
 
Join Date: Sep 2010
Posts: 29
OK! Removed and cleaned the AIC valve as well as the EVAP purge valve... just to be sure, both of those function as either entirely closed or open, right? I battery-tested both, and they actuated and seemed to be fully functional (assuming the proper way is open/close).

So, replacing those, the idle issues/hunting/surging seemed to resolve... (thanks for the recommendation, guys...) So that's a big step in the right direction.

Then cleared the CEL... took it for a long drive, and CEL is back!

The new culprits:

P0125 - Closed loop fuel control Insufficient coolant temp

P0135 - O2 sensor heater circuit malfunction (bank 1 sensor 1)

P0340 - Camshaft position sensor A - Bank 1 sensor malfunction

SO... could the coolant temperature sensor be causing all of this? After all, if it is not working, fuel/air mixture is off, potentially cause misfires, and it'll affect fuel/oxygen output. Maybe???

What do you think? I'm actually a little excited. Thinking maybe we see the light at the end of the tunnel...

Let me know! Thanks...
SwedeSpeed93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 04-30-2011, 10:49 PM   #7
TSLMember
 
Join Date: Sep 2010
Posts: 29
OR perhaps it is the thermostat that is worn... not closing entirely, and engine is taking too long to warm up, thus triggering P0125???
SwedeSpeed93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 05-02-2011, 10:49 AM   #8
Live, eat, and sleep by TSL
 
Aikmanson's Avatar
 
Join Date: Mar 2010
Location: Lomontville & Cortland, NY
Posts: 1,837
P0340 I am willing to bet is a bad ground. Clean the two grounds behind the intake manny and see if they go away. I had the same code on my 97 NA forever until I cleaned the grounds, unplugged battery and has never come back. These cars do not even have a camshaft position sensor (v6 does).

Glad to see we solved the idling issue.
__________________
Current Cars
2010 Mini Cooper S
1991 Miata
1995 900 SE Turbo
Aikmanson is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 05-02-2011, 10:59 AM   #9
Elder
 
Castor Troy's Avatar
 
Join Date: Nov 2003
Location: Montana
Posts: 3,998
is this car tuned or stock?
__________________
^The preceeding post probably had something to do with Seth Romer.
Castor Troy is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 05-02-2011, 05:04 PM   #10
TSLMember
 
Join Date: Sep 2010
Posts: 29
Two grounds behind the intake... are those pretty visible, or hidden behind/beneath? The next time I've got access to his car I'll try to do some exploring with a wrench and wire brush.

@ Castor Troy, this '99 9-3 (base) is totally stock. Nothing tuned about it! My cousin does NOT have much mechanical aptitude (not that I have much, either) - so it's probably better that way.
SwedeSpeed93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
code, idle, o2 sensor, pcv, vacuum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:44 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.