stage 3 and there goes the motor first night - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-02-2007, 10:52 PM   #1
Flirting With TSL Addiction
 
Join Date: Jun 2007
Location: albany / oneonta ny
Posts: 828
Send a message via AIM to aero93
stage 3 and there goes the motor first night

okay so i just put in jak stoll stage 3 ecu my current mods are td04 and x flow intercooler and the ecu, went out and took it for a ride 4 pulls in 4th from 50 to 90 all solid power turbo would spool past the red, i go out and dirve a little bit around long island and down to dpa but did not race the car, i stop at a light and it turns green i slowly go and then shift to second and all of a suden boom and no power pull over check around turns out its a intercooler hose rip apart my car at 2 in the morning and put it all back together it turns out it boosts fine, on my way home im cruising just still trying to get the ecu adjusted and im doing a 50mph pull when all of a sudden loss of power and the car starts to shake and ratle when im on the gas, pull over check the motor everything seems fine get back in starts fine but then it starts to shake softly again, get to school and i take out the di to see if i shot oil on my plugs turns out their okay , disconect the battery thinking maybe its the ecu , and then i get back in and drive it again this time im driving and do a slow pull and my check engine starts to blink and when i come to a stop it stays on and i hear a murrmuur from the engine and i think i might have blown the motor, im not sure how or what it would sound like but i have no idea and the car shakes under throttle ... please help i need it asap !! what could it be? why would it do this ? pre requisit is a turbo back exhaust but why would the lack of one blow my motor after asking many people would it they insited that it would run rich and not lean? i need help bad anything would be greatly appreciated thanks
aero93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-02-2007, 11:01 PM   #2
Deez Nutz
Site ModeratorElder
 
Palmer's Avatar
 
Join Date: Oct 2005
Location: Cheese Country
Posts: 15,679
Send a message via AIM to Palmer
You have a boost leak.

Your tune exposed the weaknesses in your car.

Before the grammar natzis rip you a new one, I would recommend that you make sure your car is in 100% shape before slapping a tune on it.
__________________
S55/LC100/KL
Palmer is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-02-2007, 11:04 PM   #3
Flirting With TSL Addiction
 
Join Date: Jun 2007
Location: albany / oneonta ny
Posts: 828
Send a message via AIM to aero93
a boost leak ? but it murmers no matter what even when it idles now and i cant figure it out and i checked all my line and cant to see any problems in fact i replaced them a few days ago with new silicone lines, the car will studder while on its way up to climbing boost ??
aero93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 11-02-2007, 11:11 PM   #4
Elder
 
saabkid37's Avatar
 
Join Date: Dec 2003
Location: A big city with bright lights
Posts: 8,796
what year is the car.



__________________
Quote:
The tragedy of idiot-proofing: Mother nature responds to every product improvement by introducing a higher performance idiot.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saabkid37 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-02-2007, 11:22 PM   #5
Flirting With TSL Addiction
 
Join Date: Jun 2007
Location: albany / oneonta ny
Posts: 828
Send a message via AIM to aero93
its a 99 9-3 t5
aero93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 12:35 AM   #6
HNNLIC
Elder
 
Blaque's Avatar
 
Join Date: Oct 2003
Location: Washington, D.C. / Kansas City
Posts: 4,209
Send a message via ICQ to Blaque Send a message via AIM to Blaque Send a message via MSN to Blaque Send a message via Yahoo to Blaque
Time to pull codes and do a compression check.
__________________
Virtualization FTW. IT 4 Life.

“Brothers and sisters… and friends…and I see some enemies. In fact, I think we’d be fooling ourselves if we had an audience this large, and didn’t realize that there were.. some enemies present.” –Malcolm X


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Blaque is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 12:43 AM   #7
Elder
 
Join Date: Apr 2007
Location: Phoenix
Posts: 2,012
Send a message via AIM to Saaboy Send a message via MSN to Saaboy
i was relieved when you said IC hose blew off... dunno about the rest
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Saaboy is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 05:22 AM   #8
Elder
 
Join Date: Nov 2005
Location: MI
Posts: 10,066
Send a message via AIM to Jameson
I work in farmingdale and live in Lynbrook. I am an expert at this point on boost leaks lol. Let me know if you want to meet up.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jameson is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 06:10 AM   #9
Elder
 
NahumCC's Avatar
 
Join Date: Aug 2006
Location: Columbus, OH
Posts: 9,197
Send a message via AIM to NahumCC Send a message via MSN to NahumCC Send a message via Yahoo to NahumCC
Flashing CEL was for misfires. 1.) Get new plugs 2.) Get new silicone vac lines

If there is still a problem after that continue trouble shooting and let us know what its doing.

As to the turbo back. If your system is too small you'll have high EGT's due to excessive back pressure which can cause other problems. Your DI if its old may also be dieing now.



__________________
2013 FR-S

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NahumCC is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 06:14 AM   #10
Elder
 
NickTurbo900's Avatar
 
Join Date: Sep 2005
Location: Greater Burlington, Vermont
Posts: 4,023
Oh no dude your car is ruined! I'll give you a $800 for it!


HAhah no seriously ^^^^ what they all said... then get back to us all!
NickTurbo900 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 07:19 AM   #11
Elder
 
CooperS7777's Avatar
 
Join Date: Jan 2006
Location: Lakes Region, NH
Posts: 3,171
Send a message via AIM to CooperS7777
Boost leak (turbo related anyway) doesnt usually have that kind of effect on a T5 car, though its hit or miss. It could certainly be a vacuum line - thats where I would start.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

SQR Performance, Saab Repair & Service

Quote:
Fuck the afterlife, its Miller time.
CooperS7777 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 08:10 AM   #12
Elder
 
saabkid37's Avatar
 
Join Date: Dec 2003
Location: A big city with bright lights
Posts: 8,796
yeah but a t5 car can basically run with no connection between the ic and tb vac leaks really wont make it noisy like that. do you have abost gauge?



__________________
Quote:
The tragedy of idiot-proofing: Mother nature responds to every product improvement by introducing a higher performance idiot.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saabkid37 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 08:27 AM   #13
Elder
 
mcrowley's Avatar
 
Join Date: Oct 2005
Location: Albany, NY
Posts: 12,348
Send a message via AIM to mcrowley
Yeah, boost leaks won't wreak havoc on a T5 car like a T7...still not good to have one though.

I'd say your problem is ignition. Get a fresh set of plugs, try another di.

DEFINITELY don't run it hard for very long with that stock exhaust either.
__________________
95 9000 Aero
96 900 SE
06 9-5

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mcrowley is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 08:30 AM   #14
Live, eat, and sleep by TSL
 
fretrunner9000's Avatar
 
Join Date: Aug 2004
Location: Rhode Island
Posts: 1,488
Send a message via AIM to fretrunner9000 Send a message via MSN to fretrunner9000
could also be your pvc seal is gone or just got completely blown off.

That happened to me when i first went stage 3 in the 9k and that fits all the symptoms low boost, shuddering, ok under a little bit of acceleration but shaky and rough under more then a few pounds. Id check there as well.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2003 93 Linear Stage 2
fretrunner9000 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 08:47 AM   #15
Elder
 
saabkid37's Avatar
 
Join Date: Dec 2003
Location: A big city with bright lights
Posts: 8,796
yeah but your later shaking/vibration issue was a spun bearing lol.

edit: see if you can find someone to smoke test the car.



__________________
Quote:
The tragedy of idiot-proofing: Mother nature responds to every product improvement by introducing a higher performance idiot.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saabkid37 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 10:07 AM   #16
Trollerator
Elder
 
abdukted1456's Avatar
 
Join Date: Feb 2004
Location: Albany, NY area
Posts: 9,830
can we try and not use F bombs in thread titles please. Me fixey.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1990 900 turbo vert
2004 9-5 aero sedan
abdukted1456 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 10:10 AM   #17
Live, eat, and sleep by TSL
 
fretrunner9000's Avatar
 
Join Date: Aug 2004
Location: Rhode Island
Posts: 1,488
Send a message via AIM to fretrunner9000 Send a message via MSN to fretrunner9000
Quote:
Originally Posted by saabkid37 View Post
yeah but your later shaking/vibration issue was a spun bearing lol.

edit: see if you can find someone to smoke test the car.
haha that was 2 years later!
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2003 93 Linear Stage 2
fretrunner9000 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 10:10 AM   #18
Live, eat, and sleep by TSL
 
moose's Avatar
 
Join Date: Jun 2006
Location: Manchester, NH
Posts: 1,751
Send a message via AIM to moose
Quote:
Originally Posted by abdukted1456 View Post
can we try and not use F bombs in thread titles please. Me fixey.
ya guys what the fuck.

this is some crazy stuff i'm glad nothing crazy happened when i put my JSP stg. 3 in, and still nothings happened yet.
__________________
undercover Moderator

Stg. no go
My transmission boggles minds!!!
moose is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 10:28 AM   #19
Elder
 
griffen nut's Avatar
 
Join Date: Oct 2005
Location: West Chester, PA
Posts: 2,171
Send a message via AIM to griffen nut
Sounds like the car is just missing REALLY bad

Probably a simple fix...DI, plugs, etc like every1 said.
__________________
griffen nut is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-03-2007, 12:49 PM   #20
Flirting With TSL Addiction
 
Join Date: Jun 2007
Location: albany / oneonta ny
Posts: 828
Send a message via AIM to aero93
well after all the advice i changed the plugs and put electric goo on it and it runs fine now, pep boys didnt have ngk irridium so i got another brand still platinum and it runs fine thank god.. but the boost isnt climbing as high before it would go past the red and fall back but now it just climbs to the red and stops is this a good or bad thing ? thank you guys soo much for all the help i really appreciate it all and awsome advice thanks again !
aero93 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:24 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright © The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.