Cylinder 2 not firing - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 08-21-2018, 02:34 PM   #1
SAABeginner
 
Join Date: Mar 2008
Posts: 2
Cylinder 2 not firing

Hi all, I have an issue I just can't solve. I started getting intermittent rough running, and obvious injector leakdown. Replaced the plugs, cylinder 2 plug was black, the rest good. The motor was still missing, and after running for a bit, I pulled the plugs, cylinder 2 looked fresh out of the box, the other 3 had started to brown. Now the intermittent issue is constant, no cylinder 2.

I bought a DIC, replaced it, no change.

In the midst of all this, it's throwing P0130, so I changed the O2 sensor, no change to CEL, no change to the misfire problem.

I'm at a loss because I'm sure cylinder 2 was the leakdown problem, as it had the only fouled plug, but what are the odds that the rebuilt injector I installed isn't cycling properly?? It seems a long shot that it was leaking and I replaced the same one with a DOA replacement unit.

I traced the wires back to the firewall and they seem fine, but the initial intermittent misfire sounds like a short too me.

Can the ECU cause these symptoms?

I've compression tested it, that's not a problem. I measured the resistance on the "bad" injector, it's the same as the others. One of the old injectors seemed to be cycling fine when plugged into the harness.

I'm completely stumped. Anyone seen anything like this before? I've had her for 10 years without a hiccup, now this, I'm almost ready to take her to the salvage yard where I rescued her. TIA!
StuckOnTheDock is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-22-2018, 11:16 AM   #2
Elder
 
Join Date: Sep 2004
Location: Annapolis, MD
Posts: 2,522
Send a message via ICQ to g96nt Send a message via AIM to g96nt Send a message via MSN to g96nt Send a message via Yahoo to g96nt
Sounds like you have a bad injector.
Either pick up a good spare and toss 'er in, or for diagnosis- swap them around, and see if the misfire follows.
__________________
Craig R.
2008 9-5 Aero-1995 900T 'vert
g96nt is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 08-29-2018, 05:00 PM   #3
SAABeginner
 
Join Date: Oct 2010
Posts: 5
Craig sounds sensible....you may also try swapping spark plugs....#2 might be a dud. I suppose one other possibility is a burnt valve. Check injector is clean to chassis.

The sooted plug is either not firing adequately, is defective(can't fire under compression/has breakdown to H.T.) is being overloaded/wetted by fuel or has a valve issue. You tried another coil pack....try another.

The only reliable tests come from using replacements. Yes any problem can be ecu generated, check its plugs are clean and clear of mould.
Pythagorus is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:29 PM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.