Abs and speedo and check engine light - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-17-2017, 06:23 PM   #1
SAABeginner
 
Join Date: Sep 2017
Location: Rowan County NC.
Posts: 3
Exclamation Abs and speedo and check engine light

Hi everyone... im a new owner of a nice clean 2002 9-3 convert. I have the abs not works speedo not working check engine light problem .... the abs light and speedo are connected the come on and go off at will... seems like a wireing problem or bad connection somewhere... have pulled off the back wheel connectors and greased and put back on. No change want to pull off the big electrical connector but cannot get it to release...i've seen a few comments on why to remove and grease but not as to how...if there are pics or more simple directions on how to do that i'd love it.. as to the check engine light when it comes on i dont get a code...and when i clear all codes the engine has to stall at least 3 times before it will stay running... weird...also cannot get top to go down just says failure... how can i manually get the top down? the previous owner had said something about a switch that got out of alignment?? I dont even know where to check the hydrolic fluid for the top.. if i get it down i'll probably just leave it down..its parked inside a garage....ok i'll quit now any help would be appreciated...also the name and phone of a Saab expert somewhere near here....
gentlebiker is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-18-2017, 11:26 AM   #2
SAABeginner
 
Join Date: Sep 2017
Location: Rowan County NC.
Posts: 3
update i found and disconnected the main connectorfor the ABS it had been greased earlier put it back on no change
gentlebiker is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:54 PM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.