Play in Front End - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 06-19-2016, 11:59 AM   #1
Flirting With TSL Addiction
 
Join Date: Dec 2010
Posts: 579
Play in Front End

Everything suspension wise is, at the most, 15k miles old. I have full polly bushings, and two new control arms (ball joints). When the car is jacked up on one side, and when tugging on the wheel on the steering axis (moving the wheel as if to turn right or left) there is obvious play being taken up. The only original parts front-end wise are the tie-rod ends, and the inner bushings where the tie-rods connect to the rack.

-No motion top-to-bottom (wheel bearing test)
-Ball joint is tight as tested with a pry-bar and visual confirmation
-Tie-rod end seems tight from prying at with a small crow-bar (more force maybe?)
-Stanchion-arm bushing is intact and seemingly in good shape
-The control-arm doesn't seem to move in either the subframe, or where the stanchion arms connects with it. (testing for chewed poly bushings)
-The inner bushings on the tie-rod don't seem to exhibit any play, either.

The only thing is that the passenger-side(LHD) strut mount is dome-shaped, whereas the brand-new strut mount on the other side is mildly convex as it should be.
Could it be a bad strut-mount? It doesn't make any noise, and I've never experienced a failure mode like this involving the strut-mount.
From what I could surmise, it looks like the whole strut is jogging, in addition to twisting with the direction of steering. It honestly feels like the shock piston is worn in its barrel...but I doubt it, as the B8's in the car are ridiculously beefy and have proven to take a savage beating.

I'm totally flummoxed and you wizards figured out that the strut collar was loose before. Please help!
-Cm
__________________
T5 Suite Stg GpopT28, Deka 630's, Walbro 255LPH, 3 bar MAP @ 1.92Bar, W/M, Stg2 clutch, full suspension/bushes, 308mm brake upgrade, 3" turbo-back, big-azz FMIC &Oil-cooler, and fwdlol diapers.
Cm452 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:26 PM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.