HELP! Failed DIC? Misfiring code & Very rough/sporadic idling - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 08-16-2015, 06:16 PM   #1
SAABeginner
 
Join Date: Aug 2009
Posts: 2
Question HELP! Failed DIC? Misfiring code & Very rough/sporadic idling

Hey guys,

I spent the day swapping out my TD04-15t yesterday with a new one, because I thought the problem with my 96 900SE was the turbo. I had a rougher idle and smoke from burning oil (NOT coolant) from the tailpipe. My previous TD04 had a TON of in/out ("longitudinal") shaft play, and I figured it had finally given out, leading to terrible performance.

After a proper install yesterday, the problem remains the same. My car has a VERY rough idle, noticeably less braking power, and is just not doing well. It starts up every time and does not shut off on its own, although it did stall once while I was maneuvering the car so that I could get it onto a towtruck bed.

I scanned for codes and got: P0300 (random misfiring) and P1577.

I sprayed all the relevant vacuum and brake lines for a vacuum leak - found nothing. I used a smoker machine to look for vacuum leaks - found nothing. I let it sit and idle for literally 15-20 minutes, but the idle never improved.

Is this the DIC? I've never replaced the DIC in the 3-4 years I've had this engine, and I bought the DIC used from someone else when I got the engine. So, the DIC is definitely more than 5 years old, and probably substantially older than that.

My car's fuel pump is new, engine was rebuilt like 2-3 years ago, turbo is new, seals are new, oil and coolant are not leaking or burning, there are no vacuum leaks.

What are the odds this is the DIC?


I sincerely appreciate any help you guys can give me.
dougwentzel is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:34 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.