The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   Car Problems? New 9-5 Only (https://www.saablink.net/forum/forumdisplay.php?f=106)
-   -   PLEASE HELP saab 95 3.0 not engaging drive (https://www.saablink.net/forum/showthread.php?t=71362)

phillipallman 06-01-2013 06:01 AM

PLEASE HELP saab 95 3.0 not engaging drive
 
hello guys im new to the forum i just got myself a saab 95 2003 3,o litre v6 turbo auto ;) beautifull car :) 100 k miles full service history ecvery reciept possible body work mint interior mint im happy well kind of im hoping some one could help i was driving it the other day and as i slowed down then put my foot down there was no drive :( like it was in neutral gear :S it starts first time no bangs grinds whirls etc it just free revs in every gear theres lights on the dash and it read a transmission error code but we cant figure it out i checked the tranny oil and it was way over the max so drained abit still no joy ive tryed looking around and theres tons of things it could be oil pressure toque converter gearbox gone electrical i have no idea wot to do or were to start with this im a motorbike man at heart lol soooo any ideas ???

NickTurbo900 06-01-2013 06:47 AM

What is the code?

Is the the shift cable moving the gear selector switch on the transmission?

Where are you located? UK?

You are probably going to need some (techII scan tool) help no matter what the problem is.

Maybe this is why they sold it? Did it happen really really soon after buying it?

g96nt 06-01-2013 07:38 AM

I'm not an auto trans guy, but there's not much that would cause your issue.
usually, it's an overheat, low fluid, or a "clog" in the valve-body.

Have you tried resetting the ECU/TCU?
(check the fuses, too!)

phillipallman 06-01-2013 08:03 AM

right im not sure on the code as the guy who towed it home for me did it i picked it up checked it over drove it halfway home the previouse guy only had it 3 days sead it cant afford it lol i id blast it to 100 testing it and it was fine 7 miles later ish the problem happend ive drained hte trans oil abit as it was overfull :? the gear selector is moving perfect and changing gear on the dash and on the body thing by the battery the temprature is normal on the gauge the trans and engine oil are now normal ive tryed takeing the battery off unplugging sensors taking fuses out those dash lights are still there :? it starts first click ticks over allday revs perfect it just has no drive i was told clutch or torque converter if not gearbox ?? and im in wales im debating getting rid of it its already on ebay because its really screwed me over havent been to work this week so i need transport asap and im in wales by pontypool

phillipallman 06-01-2013 09:03 AM

Quote:

Originally Posted by g96nt (Post 1829770)
I'm not an auto trans guy, but there's not much that would cause your issue.
usually, it's an overheat, low fluid, or a "clog" in the valve-body.

Have you tried resetting the ECU/TCU?
(check the fuses, too!)

wot do you fink guys with the new info and how do you reset the ecu/tcu

NickTurbo900 06-01-2013 05:01 PM

Pull battery terminals overnight.

Sorry man it doesnt sound good. Here in the US ive junked a half dozen cars with good gearboxes. They are pretty stout. If the rest of the car is that good then spend the $ and put a used one in.

Try saabcentral for more uk folks.

srp 06-01-2013 06:52 PM

Does reverse work?

phillipallman 06-02-2013 03:39 AM

hey guys nope none of the gears work ive tryed leaving the battery a few hours etc still no joy to anything :(


All times are GMT -8. The time now is 05:41 AM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.