PLEASE HELP saab 95 3.0 not engaging drive - The Saab Link Forums

Go Back   The Saab Link Forums > Saab New 9-5 '10+ Forum > Car Problems? New 9-5 Only

Car Problems? New 9-5 Only If you're experiencing problems with your new 9-5, post your question in here.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 06-01-2013, 07:01 AM   #1
SAABeginner
 
Join Date: Jun 2013
Posts: 5
PLEASE HELP saab 95 3.0 not engaging drive

hello guys im new to the forum i just got myself a saab 95 2003 3,o litre v6 turbo auto beautifull car 100 k miles full service history ecvery reciept possible body work mint interior mint im happy well kind of im hoping some one could help i was driving it the other day and as i slowed down then put my foot down there was no drive like it was in neutral gear :S it starts first time no bangs grinds whirls etc it just free revs in every gear theres lights on the dash and it read a transmission error code but we cant figure it out i checked the tranny oil and it was way over the max so drained abit still no joy ive tryed looking around and theres tons of things it could be oil pressure toque converter gearbox gone electrical i have no idea wot to do or were to start with this im a motorbike man at heart lol soooo any ideas ???
phillipallman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-01-2013, 07:47 AM   #2
Elder
 
NickTurbo900's Avatar
 
Join Date: Sep 2005
Location: Greater Burlington, Vermont
Posts: 4,023
What is the code?

Is the the shift cable moving the gear selector switch on the transmission?

Where are you located? UK?

You are probably going to need some (techII scan tool) help no matter what the problem is.

Maybe this is why they sold it? Did it happen really really soon after buying it?
NickTurbo900 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 06-01-2013, 08:38 AM   #3
Elder
 
Join Date: Sep 2004
Location: Annapolis, MD
Posts: 2,522
Send a message via ICQ to g96nt Send a message via AIM to g96nt Send a message via MSN to g96nt Send a message via Yahoo to g96nt
I'm not an auto trans guy, but there's not much that would cause your issue.
usually, it's an overheat, low fluid, or a "clog" in the valve-body.

Have you tried resetting the ECU/TCU?
(check the fuses, too!)
__________________
Craig R.
2008 9-5 Aero-1995 900T 'vert
g96nt is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 06-01-2013, 09:03 AM   #4
SAABeginner
 
Join Date: Jun 2013
Posts: 5
right im not sure on the code as the guy who towed it home for me did it i picked it up checked it over drove it halfway home the previouse guy only had it 3 days sead it cant afford it lol i id blast it to 100 testing it and it was fine 7 miles later ish the problem happend ive drained hte trans oil abit as it was overfull the gear selector is moving perfect and changing gear on the dash and on the body thing by the battery the temprature is normal on the gauge the trans and engine oil are now normal ive tryed takeing the battery off unplugging sensors taking fuses out those dash lights are still there it starts first click ticks over allday revs perfect it just has no drive i was told clutch or torque converter if not gearbox ?? and im in wales im debating getting rid of it its already on ebay because its really screwed me over havent been to work this week so i need transport asap and im in wales by pontypool
phillipallman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 06-01-2013, 10:03 AM   #5
SAABeginner
 
Join Date: Jun 2013
Posts: 5
Quote:
Originally Posted by g96nt View Post
I'm not an auto trans guy, but there's not much that would cause your issue.
usually, it's an overheat, low fluid, or a "clog" in the valve-body.

Have you tried resetting the ECU/TCU?
(check the fuses, too!)
wot do you fink guys with the new info and how do you reset the ecu/tcu
phillipallman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 06-01-2013, 06:01 PM   #6
Elder
 
NickTurbo900's Avatar
 
Join Date: Sep 2005
Location: Greater Burlington, Vermont
Posts: 4,023
Pull battery terminals overnight.

Sorry man it doesnt sound good. Here in the US ive junked a half dozen cars with good gearboxes. They are pretty stout. If the rest of the car is that good then spend the $ and put a used one in.

Try saabcentral for more uk folks.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NickTurbo900 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 06-01-2013, 07:52 PM   #7
srp
Elder
 
srp's Avatar
 
Join Date: Sep 2006
Location: Northwestern NJ
Posts: 5,108
Send a message via AIM to srp
Does reverse work?
srp is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 06-02-2013, 04:39 AM   #8
SAABeginner
 
Join Date: Jun 2013
Posts: 5
hey guys nope none of the gears work ive tryed leaving the battery a few hours etc still no joy to anything
phillipallman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:53 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.