Erratic Shifting, Stalling when Braking - The Saab Link Forums

Go Back   The Saab Link Forums > Saab New 9-3 '03+ Forum > Car Problems? New 9-3 Only

Car Problems? New 9-3 Only If you're experiencing problems with your new 9-3 post your questions in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 10-03-2020, 12:47 PM   #1
SAABeginner
 
Join Date: Feb 2016
Location: Seattle
Posts: 2
Erratic Shifting, Stalling when Braking

My 2007 9-3 2.0t has been plagued with weird symptoms for a few years. The newest and most distressing symptom is that it is starting to stall when I brake after running at 30-40 mph for.... maybe 5 minutes. This is not something I've ever experienced in an automatic, but when I had my 99 9-3 manual it was the IAC.

The other symptoms - about once every 3 months I'll get in the car in the morning and crank and crank and it just won't start. Then if I keep cranking or let it sit for a few minutes it will eventually kick and just billow white smoke for a minute or so. I'm assuming that is a flooded engine running super rich for a bit. This has never resolved, but never really gotten better either. About a month ago I started experiencing some erratic shifting it seems only when the engine (or trans) is fairly cool. Like less than 10 minutes of driving. It seems unable to decide between two gears - feels like 2nd and 3rd - and will keep trying to shift between the two. Eventually it makes a decision and if the pedal is down the car takes off like a rocket, and when it does so jerks quite violently. This doesn't ever happen at highway speed when stepping on it to get up a hill or pass, so only lower gears.

This car had the computer replaced a couple years ago when the original gave up the ghost. Was throwing which ever code corresponds to Bank 1 misfire. At the time I thought why not have the shop put in a stage 1. Don't know as though that would account for any of the above, but it made it a few years without showing up. Spark plugs are a year and a half give or take, air filter is about 6 months old, current oil is Mobil 1 with about 1000 miles on it. I did just have a P0101 - MAF sensor code and ended up cleaning out the MAF sensor and the shifting issue got worse and that is when the stalling started.

Thoughts?
aball4620 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:33 PM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.