2005 9-3 - Temperature Gauge Displaying Too High / Hot - The Saab Link Forums

Go Back   The Saab Link Forums > Saab New 9-3 '03+ Forum > Car Problems? New 9-3 Only

Car Problems? New 9-3 Only If you're experiencing problems with your new 9-3 post your questions in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-19-2016, 08:36 AM   #1
SAABeginner
 
Join Date: Mar 2013
Posts: 3
2005 9-3 - Temperature Gauge Displaying Too High / Hot

2005 Saab 9-3 1.9 TiD Vector Sport (6s manual)

I have a similar (ish) problem to this. Prior to yesterday, for the previous day or two, I had noticed that my petrol gauge was not as it should be, as the gauge was sitting roughly 1/4 of a tank higher than it should be for the amount of fuel that was in the tank. Usually, the yellow warning light comes on when the gauge needle just about touches the first of the three reserve tank lines. However, now, my petrol gauge yellow warning light comes on when the needle is pointing at slightly below 1/4 full! I decided to trust the remaining mileage numbers on the SID display instead of trusting the petrol gauge itself. Then....

Yesterday, I found myself in London in reasonably heavy traffic. I noticed that the temp gauge was moving up past the 3/4 mark, so was keeping a close and concerned eye on it. A few minutes later, it was level with the first of the three red bars! I started to panic, as I assumed that the gauge was accurate and my car was on the edge of overheating! I pulled over to have a look - the engine was certainly hot, but it didn't seem as though it was ready to pop. I should add, that at no point has the yellow "Check engine" light come on, nor have I had any other warnings from the car/dash at all, that the car was about to overheat. I am getting an occasional "check oil" warning on SID, but when the oil level is checked, it is also pretty much exactly halfway between the min and max lines on the dipstick. The oil/filter is due for service/replacement, but is this relevant? (I had assumed not for this particular temp gauge issue).

When I restarted the engine, the gauge was even higher (top of the three red bars), so the engine had theoretically got hotter whilst it was off and I was checking it. I couldn't work out what was going on, so whenever I got caught in traffic and was going to be stationary for a while, I stopped the engine to help her not to overheat. This seemed to make the gauge worse, as I noticed that when the engine was off, the temp gauge would drop/reset to the half-way point on the dash gauge. By the end of the day, and indeed now, the day after, the temp gauge now rests at the first of the three red bars as it's "reset" or "resting" point position. Prior to yesterday, my temp gauge would always sit, rock-solidly just above the 1/4 mark (on a cold day), and just under the half-way mark (on a hot sunny day) when the car was running at normal working temperature.

I've read a few posts on the net, which talk about various fixes for this. As a result of following the tips - I've:

* Removed fuse F4 from the passenger glove box fuse box. This is supposed to cut the feed to the dash instrument cluster. It's been removed for a couple of hours now, and it's made no difference, as the needle still sits, at rest, at the first of the three red bars. The fuel gauge is also still wrong too.

* I've also removed F1 and F4 fuses from the engine bay fuse box, as these should cut the feed to the ECU. This also made no difference.

* I've also completely disconnected the battery to effectively "reset" the car. The battery has also been disconnected for a couple of hours, and this has also made no difference either! (I've left it disconnected for the time being in case there is any residual charge anywhere in the system that is propping up the dash gauge falsely.


I was using the car earlier this morning, and checked whether pressing the nightpanel light made the needles drop. It did. The temp gauge dropped, but only back down to its new, stupidly-high resting place of the first of the three red bars, and the fuel gauge also dropped, but only to its incorrect new resting position of the third of the red reserve tank bars.

Therefore, from, what I've done, I feel confident that the fault doesn't lie with either the engine temp sensor or the coolant temp sensor? Given that the engine was bone cold from resting overnight, and has now also had all power removed from it, if the sensors were sending a duff signal - the removal of power should still have reset the temp and fuel needles to their normal resting points? That's my theory anyway.

1 - I've read on another forum that I'll need a Tech2 diagnosis to read the codes. I'm also a Land Rover owner, and there's a large swathe of owners that have Nanocom computers that can be plugged in and do pretty much all of the jobs that a main stealer computer can do. Is there a Saab equivalent?

2 - I've also read on this very thread, that apparently gauge needles can "slip" on their spindles. Is this correct? Can the instrument cluster be removed and these needles to "moved" or "reset" back to where they should be so that point in the correct range in the future?

3 - Is there anything I should be checking to ensure that I've diagnosed this correctly?

Many thanks for any help or diagnosis to help sort out this super-niggly problem!
rjsdavis is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
9-3 temp, displaying far too high, hot, temperature gauge

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:41 PM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.