The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   Car Problems? Classic 900 Only (https://www.saablink.net/forum/forumdisplay.php?f=57)
-   -   1993 C900 2.1 Runs, heats up, dies, cools, re-starts (https://www.saablink.net/forum/showthread.php?t=121665)

t-nam 10-20-2020 01:06 PM

1993 C900 2.1 Runs, heats up, dies, cools, re-starts
 
Hi. My '93 2.1 starts and seems to run fine - till it warms up a bit. Then whether idling or driving, it will stall. It will not restart until it cools off. Then it repeats the same thing. Max runs for about 20 minutes.

I replaces the mass airflow sensor cuz it is so easy. Have gone no further yet. Appreciate the help.

t-nam 10-20-2020 01:43 PM

1993 900S 2.1 convertible 44k miles

ninehundredt 10-21-2020 07:21 AM

This is a common symptom of a failing crank position sensor. I would check that first.


Sent from my LM-Q910 using Tapatalk

t-nam 10-23-2020 08:06 AM

thanks -- will have to look into that!

t-nam 10-23-2020 08:51 AM

doesn't seem like an easy change necessarily.... sigh Any advice?


All times are GMT -8. The time now is 03:54 PM.

Powered by vBulletin® Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.