The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   Car Problems? 9-5 Only (https://www.saablink.net/forum/forumdisplay.php?f=48)
-   -   no fuel out of injectors (https://www.saablink.net/forum/showthread.php?t=79298)

themaverick 09-28-2013 10:38 AM

no fuel out of injectors
 
:wtf: I have a new crank sensor, a good di that was check and started another 9-5. it also started with starting fluid sprayed into intake so no fuel is getting to cylinder. have no signal at injectors(with all but one connected and then all disconnected) with noid light. i also have pressure at fuel rail but if no signal at injectors that doesn't matter right? I miss my saab can anyone figure this out!!!!!? about 6 months ago I had head gaskets replaced got it home for a day. then no start because of teeth broken off flywheel fixed that got it back and that's when this started. it would run then die ,sometimes it would start right back but others no start for a few min. that went on for a few days then got really bad I HAD TO HOLD DOWN GAS PEDAL THE WHOLE TIME to get it home! the next day tried to start it but it cranked with no start. replaced crank sensor and dic and that's where you guys come in, any suggestion will help track this down thanks for your help

9-3_newbie 03-23-2014 07:19 PM

Quote:

Originally Posted by themaverick (Post 1900314)
:wtf: I have a new crank sensor, a good di that was check and started another 9-5. it also started with starting fluid sprayed into intake so no fuel is getting to cylinder. have no signal at injectors(with all but one connected and then all disconnected) with noid light. i also have pressure at fuel rail but if no signal at injectors that doesn't matter right? I miss my saab can anyone figure this out!!!!!? about 6 months ago I had head gaskets replaced got it home for a day. then no start because of teeth broken off flywheel fixed that got it back and that's when this started. it would run then die ,sometimes it would start right back but others no start for a few min. that went on for a few days then got really bad I HAD TO HOLD DOWN GAS PEDAL THE WHOLE TIME to get it home! the next day tried to start it but it cranked with no start. replaced crank sensor and dic and that's where you guys come in, any suggestion will help track this down thanks for your help

Did this ever get resolved? i have a 99 9-3 doing the same thing. new fuel pump,relay, cps and DIC. my car has been down for 6 months because of this.

oliversexpedition 03-23-2014 09:26 PM

Start, no start, just had this on a 9-5 and it was the intake pipe at the throttle body was loose, would start sometimes, same as intercooler pipe loose.

99 9-3 random no start, check electrical connections to starter/solenoid, extra o ring in CPS, fuel filter. There is a 9-3 checklist for no start, fuel, spark and Neutral safety switch.

9-3_newbie 03-25-2014 07:12 PM

99 9-3 random no start, check electrical connections to starter/solenoid, extra o ring in CPS, fuel filter. There is a 9-3 checklist for no start, fuel, spark and Neutral safety switch.[/QUOTE]

Thanks for the reply. Starter turns motor over well. Is that what you meant by checking the connections at the starter? Has good spark. Fuel pump and filter replaced. New cps. Will start on starting fluid. No fuel getting to cylinders. I will ask mechanic about the neutral switch.


All times are GMT -8. The time now is 06:01 AM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.