excessive vibration 2004 9-5 2.3t wagon - The Saab Link Forums

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-22-2014, 02:52 AM   #1
SAABeginner
 
Join Date: Dec 2014
Posts: 2
Cool excessive vibration 2004 9-5 2.3t wagon

Recently bought 2004 9-5 Wagon 2.3t; excessive vibration at idle and more so in gear with brake on. any thoughts on cause/fix? (service/dealer mentioned car having short belt in lieu of long belt).
Newsaabi is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-22-2014, 04:26 AM   #2
Avid TSL User
 
Join Date: Dec 2010
Location: Brunswick, Ga & Cedar River, Mi
Posts: 131
Your motor mounts are worn out. Not too expensive and not that hard to replace.
Mike Brennan is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-23-2014, 08:11 PM   #3
SAABeginner
 
Join Date: Dec 2014
Posts: 2
Dealer still says problem is having a short serpentine belt vs long belt. Says that Saab did this to save money - doesn't make complete sense to me. They say mounts are all okay. I recently had transmission mount replaced (it was bad) but had no effect on vibration. Guess I can pay for new long belt (idler arm to accommodate long belt is installed) and see what happens.
Newsaabi is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 12-24-2014, 06:26 AM   #4
Live, eat, and sleep by TSL
 
Join Date: Aug 2010
Location: Glen Mills, PA (Phila)
Posts: 1,543
That sounds pretty bogus to me.

Usually when one motor mount gets really bad, it puts undo stress on the other ones, and they fail soon after. On transverse engine mounted, front wheel drive cars, transmission mounts are the same as engine mounts.

A bad misfire or running condition would cause similar vibration or shake, but you would probably have a check engine light to show for it.

The belt alone is not a viable answer. Has the car always vibrated with this belt on?
BuHuSPG is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-24-2014, 07:56 AM   #5
Elder
 
Drew in Houston's Avatar
 
Join Date: Aug 2006
Location: PA/MD
Posts: 2,430
Has the dealer plugged into the car to verify anything yet? First thing I'd check is vacuum at idle. What rpm is it idling at? Is it missing? I'd do good a visual once over on all hoses/connections and look for breaks
__________________
Co-Founder:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
First T7 19T turbo setup. First T7 Deka 80lb. injector setup.
Drew in Houston is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
vibration

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:56 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.