Creaking from the front end - The Saab Link Forums

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 06-10-2014, 05:55 AM   #1
TSLMember
 
Join Date: Sep 2012
Location: Mainly Providence RI, and Exeter NH
Posts: 97
Creaking from the front end

Sounds like the creaking bow of an old wooden ship. Only makes the sound when turning at slow speeds, or by moving the steering wheel left and right in the driveway.

-I've jacked the car and let the wheels hang: couldn't determine which side it was on as the sound was uniform.
-SAAB dealer said it was most likely the sway bar end links so I replaced them (they were pretty shot..) Sound is still there.
-SAAB dealer inspected all suspension components: all checks out apparently.

Could it be something in the steering column?
Slabonator is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-10-2014, 01:13 PM   #2
Elder
 
Join Date: Sep 2004
Location: Annapolis, MD
Posts: 2,522
Send a message via ICQ to g96nt Send a message via AIM to g96nt Send a message via MSN to g96nt Send a message via Yahoo to g96nt
On my old 9-3, the sound you reference was the swaybar bushings... not the end-links, but the ones that hold the bar to the subframe. Although, that only happened when the bar was twisting.
__________________
Craig R.
2008 9-5 Aero-1995 900T 'vert
g96nt is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 06-18-2014, 05:59 AM   #3
TSLMember
 
Join Date: Sep 2012
Location: Mainly Providence RI, and Exeter NH
Posts: 97
Ended up being the strut tower mounts. Popped the top covers, sprayed in some white lithium grease, sound is gone.. for now.
Slabonator is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:31 PM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.