Ticking starting at about 2k rpm - The Saab Link Forums

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-15-2013, 07:14 AM   #1
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3
Ticking starting at about 2k rpm

'02 9-5 Aero that had a bad head. Sounded like a failed valve. Replaced the head with a known good one. Ran the car and now there's a tick starting about 2k rpm. Sounded like it was coming from the injectors. Replaced those with known good ones.

2k+ rpm tick is still there. Did the wood dowel test on the valve cover to be sure the sound wasn't coming from the intake valves. Still sounds like it's coming from the injectors.

Would a bad seal or an injector not seated right cause this? It's loud enough you can hear it in the cabin so I'm thinking not. Never experienced this before so I'm at a loss.
__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-15-2013, 07:22 AM   #2
TSLMember
 
Join Date: Aug 2013
Location: N. Central, MASS
Posts: 53
Send a message via AIM to tapper
Get a mechanic stethoscope and prod around everywhere til u find where its loudest... don't forget the block...sound travels and is tricky.
tapper is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-15-2013, 12:03 PM   #3
Elder
 
Legit's Avatar
 
Join Date: Jun 2007
Location: St. Paul, MN
Posts: 2,983
Could be a worn oil pump / housing. Only thing is you have to pull the head to get at the housing.
__________________
2002 Viggen Convertible
Legit is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 11-15-2013, 06:37 PM   #4
SAAB Road Master
 
93viggen's Avatar
 
Join Date: May 2011
Location: California.
Posts: 349
Did you use the lifters from the bad head..?
__________________
Using waste to make haste!
93viggen is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-16-2013, 04:32 AM   #5
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3
Quote:
Originally Posted by 93viggen View Post
Did you use the lifters from the bad head..?
The entire head came over as a unit. The car the head came off with was drivable with no noise.

The more I think about it the more I'm inclined to say it's early rod knock.
__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-16-2013, 08:40 PM   #6
Live, eat, and sleep by TSL
 
Join Date: Aug 2010
Location: Glen Mills, PA (Phila)
Posts: 1,543
Want to post a vid of the sound? It never seems like rod knock can be confused with any top end ticking, but without hearing it, it is tough to tell.

Rod knock is just so much more violent sounding...
BuHuSPG is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-16-2013, 08:43 PM   #7
Live, eat, and sleep by TSL
 
Join Date: Aug 2010
Location: Glen Mills, PA (Phila)
Posts: 1,543
And your sure you have good oil pressure? You know all the traditional worries with sludge, oil pressure relief valves and such...

Your sounds starts at 2K and continues up through the RPMs? I doubt you've revved the piss out of it, but does the sounds progress up, or does it stop at a point?
BuHuSPG is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-16-2013, 08:57 PM   #8
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3
I can get a video soon.

The sound becomes noticeable about 1.5k rpm and goes up. Haven't taken it over 3k to see it continues. Oil pressure was good up by the sender on the back of the block. I bought a mechanical gauge a while back.

It's deffinantly a little more than a tick. I'll post a video sometime soon. Late nights/early mornings for work cause little time to work with the car.
__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 11-16-2013, 08:58 PM   #9
Live, eat, and sleep by TSL
 
Join Date: Aug 2010
Location: Glen Mills, PA (Phila)
Posts: 1,543
I hear ya man. Good luck.
BuHuSPG is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-02-2013, 05:40 PM   #10
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3
I'll post some pictures soon, but the #3 rod bearing is totally shot. Surprised it didn't spin. #2 was in ok condition. Cylinder walls look good and the crank only shows a tiny score on the #3 position. Going to measure it and see if I can get it away without having to have it turned.

Hoping to get away with just new rod bearings and piston rings and not having to drop the motor.
__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-02-2013, 06:28 PM   #11
Elder
 
oliversexpedition's Avatar
 
Join Date: Aug 2005
Location: Dulles, VA
Posts: 2,014
Check the mains, have a 9-5 engine at the mechanist with spun rod and main bearings.

Quote:
Originally Posted by Marks9-3 View Post
I'll post some pictures soon, but the #3 rod bearing is totally shot. Surprised it didn't spin. #2 was in ok condition. Cylinder walls look good and the crank only shows a tiny score on the #3 position. Going to measure it and see if I can get it away without having to have it turned.

Hoping to get away with just new rod bearings and piston rings and not having to drop the motor.
__________________
99 9-5 Wagon
01 9-5 Sedan
99 9-5 Wagon parting out
94 C900 Vert - Sold
94 325i Vert
oliversexpedition is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-02-2013, 06:28 PM   #12
Wagon Shaggin'
Site Moderator
 
Saabeh's Avatar
 
Join Date: Mar 2007
Location: Ayer, MA
Posts: 6,706
How many miles were on the bottom end?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
The only reason it took all day to install was because we couldn't keep our dicks out of each others mouths.
Saabeh is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-02-2013, 06:35 PM   #13
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3
Quote:
Originally Posted by oliversexpedition View Post
Check the mains, have a 9-5 engine at the mechanist with spun rod and main bearings.
I did the work with the motor in the car. All I'll be able to check are the bottoms of the middle ones. Planning on it to at least have an idea.

Quote:
Originally Posted by Saabeh View Post
How many miles were on the bottom end?
138k. But unknown service history prior to about 125k miles.
__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-03-2013, 07:19 AM   #14
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3
Here is the #3 rod bearing. Caught it just in time for sure with nothing but copper showing.

__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3

Last edited by Marks9-3; 12-03-2013 at 07:21 AM.
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-11-2013, 11:20 AM   #15
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3


Got the goods to put it back together including the updated air intake thing from the '04+.

Piston Rings
Rod Bearings
Gaskets
Vacuum Hose
Head Bolts
Misc O-Rings
__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-11-2013, 05:44 PM   #16
Elder
 
jssaab's Avatar
 
Join Date: Aug 2006
Posts: 2,929
Did you check the mains???
jssaab is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 12-12-2013, 07:31 AM   #17
Elder
 
Marks9-3's Avatar
 
Join Date: May 2004
Location: Central, CT
Posts: 3,348
Send a message via AIM to Marks9-3
Quote:
Originally Posted by jssaab View Post
Did you check the mains???
Only the bottom of the middles ones, engine is still in the car. They were all fine.
__________________
'96 900SE Stg 4 RIP | '97 900SE Gone | '98 900SE Gone |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| '02 9-5 Aero | '04 9-5 Aero Stg 3
Marks9-3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:24 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.