no fuel out of injectors - The Saab Link Forums

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-28-2013, 10:38 AM   #1
SAABeginner
 
Join Date: May 2013
Posts: 7
no fuel out of injectors

I have a new crank sensor, a good di that was check and started another 9-5. it also started with starting fluid sprayed into intake so no fuel is getting to cylinder. have no signal at injectors(with all but one connected and then all disconnected) with noid light. i also have pressure at fuel rail but if no signal at injectors that doesn't matter right? I miss my saab can anyone figure this out!!!!!? about 6 months ago I had head gaskets replaced got it home for a day. then no start because of teeth broken off flywheel fixed that got it back and that's when this started. it would run then die ,sometimes it would start right back but others no start for a few min. that went on for a few days then got really bad I HAD TO HOLD DOWN GAS PEDAL THE WHOLE TIME to get it home! the next day tried to start it but it cranked with no start. replaced crank sensor and dic and that's where you guys come in, any suggestion will help track this down thanks for your help
themaverick is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-23-2014, 07:19 PM   #2
TSLMember
 
Join Date: Feb 2013
Posts: 44
Quote:
Originally Posted by themaverick View Post
I have a new crank sensor, a good di that was check and started another 9-5. it also started with starting fluid sprayed into intake so no fuel is getting to cylinder. have no signal at injectors(with all but one connected and then all disconnected) with noid light. i also have pressure at fuel rail but if no signal at injectors that doesn't matter right? I miss my saab can anyone figure this out!!!!!? about 6 months ago I had head gaskets replaced got it home for a day. then no start because of teeth broken off flywheel fixed that got it back and that's when this started. it would run then die ,sometimes it would start right back but others no start for a few min. that went on for a few days then got really bad I HAD TO HOLD DOWN GAS PEDAL THE WHOLE TIME to get it home! the next day tried to start it but it cranked with no start. replaced crank sensor and dic and that's where you guys come in, any suggestion will help track this down thanks for your help
Did this ever get resolved? i have a 99 9-3 doing the same thing. new fuel pump,relay, cps and DIC. my car has been down for 6 months because of this.
9-3_newbie is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 03-23-2014, 09:26 PM   #3
Elder
 
oliversexpedition's Avatar
 
Join Date: Aug 2005
Location: Dulles, VA
Posts: 2,014
Start, no start, just had this on a 9-5 and it was the intake pipe at the throttle body was loose, would start sometimes, same as intercooler pipe loose.

99 9-3 random no start, check electrical connections to starter/solenoid, extra o ring in CPS, fuel filter. There is a 9-3 checklist for no start, fuel, spark and Neutral safety switch.
__________________
99 9-5 Wagon
01 9-5 Sedan
99 9-5 Wagon parting out
94 C900 Vert - Sold
94 325i Vert
oliversexpedition is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 03-25-2014, 07:12 PM   #4
TSLMember
 
Join Date: Feb 2013
Posts: 44
99 9-3 random no start, check electrical connections to starter/solenoid, extra o ring in CPS, fuel filter. There is a 9-3 checklist for no start, fuel, spark and Neutral safety switch.[/QUOTE]

Thanks for the reply. Starter turns motor over well. Is that what you meant by checking the connections at the starter? Has good spark. Fuel pump and filter replaced. New cps. Will start on starting fluid. No fuel getting to cylinders. I will ask mechanic about the neutral switch.
9-3_newbie is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:48 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.