2004 TiD Swirl Valve Issue - The Saab Link Forums

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 05-14-2013, 04:56 AM   #1
SAABeginner
 
Join Date: Apr 2013
Posts: 2
2004 TiD Swirl Valve Issue

Below is an issue I currently have with my 2004 9-5 Vector 2.2TiD (Y22DTR) Automatic.


Symptoms
• Initially I noticed a strange cyclic chuffing noise when accelerating, with the engine speed at around 1800 to 2000 rpm. It seemed to come from the front of the car on the offside, and it sounded very much like the pads were rubbing on a brake disc with runout, but lifting off the throttle made it go away, and was still there if I left foot braked, so definitely not the brakes.
• If I accelerated with the engine speed at about 1500 rpm, I did not notice it, nor under very hard acceleration - probably drowned out by the engine noise! Tried with aircon in eco mode, and gearbox in sports mode etc, but neither make any difference.
• I could get get it to happen when stationary with the bonnet up, but only with the gearbox in D, not in when in P or N.
• The car feels a bit lacklustre between 1500 & 2000 rpm, but feels a bit better nearer 2500. I have also had the engine stuttering a bit, and the rev counter needle wobbling at about 60mph, again when revs are in the 1800rpm area, but at this speed cannot tell if chuffing noise is there.
• I have put an audio clip of the nose on YouTube at:-



Fault Finding So Far

I have a Bluetooth OBD2 & Torque app on my phone, but no fault codes were found on checking. As the noise appeared to be coming out via the air intake, I decided that the issue was likely to be somewhere between the air filter and the inlet valves, so I worked through them

• Air Filter - Removed & checked, no obvious issues.

• MAF Sensor - Removed & cleaned, no improvement.

• Vacuum Pipes - I did find that the vacuum tubes were past their best, so replaced them with 3mm bore silicon tube. Needed 4m, and it was quite easy once the battery & its tray were removed. No improvement.

• Turbocharger - The Turbo spins fine, with a little loose play. The actuator works OK, it pulls down when revved from idle, and releases momentarily when lifting off. Using the Torque app, I can see that it boosts upto about 1.3 bar. I tried running car without any vacuum to actuator (i.e. vanes set for min boost). No chuffing noise, but poor performance.

• Intercooler Hoses – I could not find any splits, and I do not get much smoke which is the usual sign that there is a split.

• Map Sensor - Removed & cleaned, no improvement.

• EGR Valve - Had this in & out like a yoyo cleaning it up, the action was nice & smooth. I pulled the plastic cover off the EGR, and watched what it was doing. With car in drive & rpm at around 2000, the EGR started oscillating and the chuffing noise could be heard. I have put a video of it on You Tube at Saab 9 5 EGR Operation - YouTube. I changed it for second hand unit, but it made no difference to the problem.

• Swirl Valves – I noticed that the vacuum actuator for the swirl valves was not being pulled in when the engine was started. According to Saab WIS:- "The purpose of the swirl throttle is to close the tumble duct at light engine loads, forcing all the air to take the longer swirl duct. This increases the air speed and provides better cylinder filling. When the engine speed and thus the amount of air increase, the tumble duct throttle opens to make the air required by the engine available." If this is the case, then I would have expected them to be closed with the engine idling, however when looking at the vacuum actuator under the bonnet, the valves are still open. I had a chat with someone with a 2.2 TiD engine in his 9-5. On his car, when the engine is started & idling, and a vacuum is created, the swirl valve actuator pulls in the arm, which in turn closes the swirl valves. This is the actuator on the RHS of the intake manifold looking from the front (may need to remove the engine cover to see it). You can see a similar thing happening with the actuator for the turbo on the back of the engine. On my car, the actuator for the swirl valves does not pull in.

o Swirl Valve Actuator – this closes when a vacuum is applied using my vacuum pump, and also closes when vacuum piping is changed to apply a constant vacuum. I concluded that the actuator itself is OK.

o Vacuum Valve / Solenoid – I bought & fitted a replacement vacuum valve, but it made no difference and on bench testing the old one, I found it was working OK. The vacuum valve is receiving a 13.7V supply from the fusebox, and it is operated by switching the earth within the fuel pump ECU module. This wire appears to be reading approx. 3.3V, so can conclude that issue is not a damaged wire. I also wired the vacuum solenoid to the battery via a toggle switch & fuse, with the switch off the actuator was out and with the switch on, the actuator pulled in, so this again proves the vacuum tubes, actuator and vacuum valve are all OK. I plumbed in a vacuum gauge between the vacuum valve and the actuator, and had the gauge inside the car whilst driving around. There was no vacuum reading at all, so I am sure that my valves are open all the time.

On the 27th Feb, I decided to plumb the vacuum tubes so that the swirl valve actuator receives a constant vacuum, i.e. the swirl valves are always closed, just to see what effect it had. This made quite a difference with the car pulling much better from low revs, and even better, it has not made the chuffing noise either.

Having got as far as I could, I decided to let a “Saab Specialist” have a look at it. It was checked using Tech2, but this did not come up with any issues, and they went through the cleaning & checking of sensors / valves / egr etc. but effectively gave up after having it for 3 weeks. They also managed to return it with one of the vacuum pipes disconnected, which put the car into limp home, whilst towing my caravan – not impressed with that!

At the moment, the vacuum pipe to the swirl valve actuator is tee’d off the turbo actuator vacuum pipe (so should initially be closed, and then opens as the engine speed increases), so car is OK to drive, but it still seems to lack power below 2000rpm.

So my question is:-
• Has anyone else had a similar problem with their 2.2 TiD?
• Does anyone have any ideas as to the cause of my swirl valves staying open?

A long post, so thanks for reading to the end!
ashley750 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-14-2013, 08:32 AM   #2
Elder
 
DrewP's Avatar
 
Join Date: Dec 2006
Location: Los Angeles, CA
Posts: 3,021
There were no diesel cars sold in the US (members here are predominantly from the US), I'd try posting this on SaabCentral if you haven't already. Most of them are in the UK, you might have more luck getting a response.
__________________
(Former) Saab Tech / Competition Prep

Quote:
You still don't understand. This is like trying to explain calculus to a clam.
DrewP is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 05-14-2013, 10:55 AM   #3
SAABeginner
 
Join Date: Apr 2013
Posts: 2
I have tried UK Saabs & Saabscene. I'm just posting on any Saab site I can find, on the off chance that someone has some ideas as to what is wrong. Thanks for your reply.
ashley750 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 05-14-2013, 10:59 AM   #4
 
mike saunders's Avatar
 
Join Date: Mar 2004
Location: Boston, MA
Posts: 6,468
Definitely try Saab Central.

To my knowledge, there are only a handful of diesels in all of North America...
mike saunders is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 05-14-2013, 04:50 PM   #5
Elder
 
NickTurbo900's Avatar
 
Join Date: Sep 2005
Location: Greater Burlington, Vermont
Posts: 4,023
You could also try finding other car makes that use the same 2.2 TiD motor and posting there. It's an Izuzu motor iirc.
NickTurbo900 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:15 PM.


Powered by vBulletin® Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
All content is copyright © The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.