Xenon light failure question - The Saab Link Forums

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-25-2009, 03:15 PM   #1
Elder
 
9000Andrew's Avatar
 
Join Date: Nov 2008
Location: East Berne, Ny
Posts: 2,950
Send a message via AIM to 9000Andrew
Xenon light failure question

Ok, so I have an 03 9-5 Aero with Xenon headlights. I LOVE the headlights, but I have a strange issue with one of the headlights:

I'll turn the car on, switch the lights on, drive for a while, and then upon coming to a stop or turning, the drivers headlight will blink in and out and then eventually go out....like it's being shorted out or something.

I'm not an expert on Xenon lighting, but I can get the light to come right back on if I switch the headlight on/off. If I do that, it will come back on, be good for some random time period (30 seconds or 10 minutes.>) and then go out again. The fact that it will turn back on makes me believe the actual bulb isn't bad, but i'm not sure. All the while, the passenger headlight never has any problem at all.

Has anybody else had an issue like this? If you haven't, do you have any ideas? Ignitor? Relay? Ballast? It's a problem I can live with but it's beyond annoying and I'd like to have it fixed. Any insight would be great as I don't want to have to buy expensive shit if I know I won't need it.

Thanks
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2006 9-3 Aero 6mt
2005 9-3 Aero auto (wife's ride!)
9000Andrew is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-25-2009, 04:23 PM   #2
Live, eat, and sleep by TSL
 
Join Date: Mar 2006
Location: Southern California
Posts: 1,857
I've had mine passenger side Xenon flicker upon hard stopping a few times. I always figured the forces were just putting strain on one of the connections... maybe one of yours is a little loose?
Aero02 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:43 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.