This is getting old really quick - The Saab Link Forums

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-15-2009, 08:34 PM   #1
Elder
 
Moreboost's Avatar
 
Join Date: Jul 2008
Location: Dirty Jersey
Posts: 3,739
Send a message via AIM to Moreboost
This is getting old really quick

The turn signals decided to stop working today. I checked the fuses and everything looks good, the hazards also work. Im stumped

HELP ME plz
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Moreboost is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-15-2009, 08:40 PM   #2
Live, eat, and sleep by TSL
 
Harvey's Autohaus's Avatar
 
Join Date: Sep 2008
Location: baltimore
Posts: 1,643
Unplug the Battery and Let Twice go to Sleep. Retest in the morning
__________________
HakbarSAABzzz
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
You can only buy what is sold to you.
Harvey's Autohaus is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-15-2009, 08:42 PM   #3
Elder
 
Moreboost's Avatar
 
Join Date: Jul 2008
Location: Dirty Jersey
Posts: 3,739
Send a message via AIM to Moreboost
Quote:
Originally Posted by Harvey's Autohaus View Post
Unplug the Battery and Let Twice go to Sleep. Retest in the morning
alright ill do that right now, thanks harvey
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Moreboost is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 07-19-2009, 11:50 AM   #4
Elder
 
Moreboost's Avatar
 
Join Date: Jul 2008
Location: Dirty Jersey
Posts: 3,739
Send a message via AIM to Moreboost
no luck, what else could be the problem?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Moreboost is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 12:28 PM   #5
Live, eat, and sleep by TSL
 
Join Date: Mar 2006
Location: Southern California
Posts: 1,857
Is the stanchion for the blinkers messed up? I've had problems with mine in the past, and I've read about them breaking... both the plastic piece itself, and the wiring going through the column.

Otherwise I have no idea :/
Aero02 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 12:37 PM   #6
Elder
 
Moreboost's Avatar
 
Join Date: Jul 2008
Location: Dirty Jersey
Posts: 3,739
Send a message via AIM to Moreboost
Quote:
Originally Posted by Aero02 View Post
Is the stanchion for the blinkers messed up? I've had problems with mine in the past, and I've read about them breaking... both the plastic piece itself, and the wiring going through the column.

Otherwise I have no idea :/
i dont think so, i guess ill have to pull the steering wheel off and take a look
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Moreboost is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 01:00 PM   #7
Elder
 
turbojohnny's Avatar
 
Join Date: Feb 2008
Location: Orchard Park, ny
Posts: 3,884
did you check your blinker fluid?
turbojohnny is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 01:04 PM   #8
Elder
 
Moreboost's Avatar
 
Join Date: Jul 2008
Location: Dirty Jersey
Posts: 3,739
Send a message via AIM to Moreboost
Quote:
Originally Posted by turbojohnny View Post
did you check your blinker fluid?
that was the first thing i checked, i topped it up dont worry

in fact if your curious i used this, amazing stuff i tell you. You cant even hear them blink

__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Moreboost is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 01:22 PM   #9
Elder
 
turbojohnny's Avatar
 
Join Date: Feb 2008
Location: Orchard Park, ny
Posts: 3,884
well then how about the bulbs, it's an off chance but you never know.
turbojohnny is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 01:30 PM   #10
Elder
 
BurnsSide42's Avatar
 
Join Date: Oct 2003
Location: South Eastern PA
Posts: 10,049
Sedan or Wagon? If sedan - it is possible for the trunk harness to break and short out the system - usually just a blown fuse and a harness repair corrects this, but typically it's "some lights" not an entire system as a symptom - worth a peek however.

The SID & Twice also control this function - has your SID been "repaired" recently?
__________________
Original TSL Founding Member - ADMIN
Check out
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for your repair needs
BurnsSide42 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 08:37 PM   #11
Elder
 
Moreboost's Avatar
 
Join Date: Jul 2008
Location: Dirty Jersey
Posts: 3,739
Send a message via AIM to Moreboost
Quote:
Originally Posted by BurnsSide42 View Post
Sedan or Wagon? If sedan - it is possible for the trunk harness to break and short out the system - usually just a blown fuse and a harness repair corrects this, but typically it's "some lights" not an entire system as a symptom - worth a peek however.

The SID & Twice also control this function - has your SID been "repaired" recently?
Ill take a look at the harness, but iv only noticed the turn signals not working, and its not the bulbs because the hazards work. The SID i repaired a while ago with some felt, ill disconnect it and see if its that
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Moreboost is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-19-2009, 08:41 PM   #12
Elder
 
Castor Troy's Avatar
 
Join Date: Nov 2003
Location: Montana
Posts: 3,998
i'll give you $750 for the car inram
__________________
^The preceeding post probably had something to do with Seth Romer.
Castor Troy is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-20-2009, 05:41 AM   #13
Flirting With TSL Addiction
 
someguy's Avatar
 
Join Date: Mar 2007
Location: Concord, NH
Posts: 978
Send a message via AIM to someguy
Quote:
Originally Posted by Castor Troy View Post
i'll give you $750 for the car inram
$751.

Also I found a diagram that should help.
__________________
President and Founder of the NJSA- "We bring nothing to the table."

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1999 M3 Cabrio
someguy is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-20-2009, 05:50 AM   #14
Elder
 
Join Date: May 2007
Location: Green Bay, WI
Posts: 3,270
Send a message via AIM to PoisonBeef
are hazzards and turn signals on the same relay? My turns work, buy I haven't had hazzards for over a year.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

99 3-door 9-3 - SOLD
99 5-door 9-3SE - td04, 3" dp, t5 suite - Sold

2001 Audi a6 2.7 twin turbo
1986 Audi 5000 2.2 turbo
2012 VW Golf TDI
1982 Yamaha Seca xj650
PoisonBeef is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 08-09-2009, 10:32 AM   #15
Elder
 
Moreboost's Avatar
 
Join Date: Jul 2008
Location: Dirty Jersey
Posts: 3,739
Send a message via AIM to Moreboost
I finally got around to taking a look at the 9-5. I pulled off the airbag/steering wheel and changed the turn signal switch i had laying around. Put everything back together and same issue, no turns. The rest of the switches work, high beams cruise control etc etc. Iv looked at the fuses and i cant find anything wrong. What else could it be? Iv let the car sit overnight with the battery disconnected but still nothing
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Moreboost is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 08-09-2009, 10:49 AM   #16
Flirting With TSL Addiction
 
bsuarmy's Avatar
 
Join Date: Feb 2007
Posts: 641
Finish your engine.

Also...$752

Last edited by bsuarmy; 08-09-2009 at 10:50 AM. Reason: grammar nazis
bsuarmy is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 08-09-2009, 01:43 PM   #17
Live, eat, and sleep by TSL
 
Join Date: Mar 2006
Location: Southern California
Posts: 1,857
Did you try what Burnsside said? The trunk harness?
Aero02 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 08-09-2009, 08:15 PM   #18
TSLMember
 
Join Date: Aug 2009
Posts: 70
mine only work with the rght turn signal. left worked yesterday, but not at all today? could it be the whole turn signal stalk? like the lever for the signals is bad?
BLK4DR is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 08-09-2009, 08:19 PM   #19
Elder
 
Castor Troy's Avatar
 
Join Date: Nov 2003
Location: Montana
Posts: 3,998
i agree with trunk harness

my dad had this same issue.

ripped apart the trunk, and about 1/4 of the trunk wires were creased, had the sheathing ripped away, or simply cut in half
__________________
^The preceeding post probably had something to do with Seth Romer.
Castor Troy is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 08-10-2009, 07:01 AM   #20
TSLMember
 
Join Date: Aug 2009
Posts: 70
could this problem be from the fact that my SID display isnt functioning? like its blank.
BLK4DR is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:27 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.